Need assistance or guidance?

Contact us @: 1-800-301-9097
Login / Register Contact Us
 
Moxa NPort 6650-32-G2-T - 32-port RS-232/422/485 secure device server, certified with IEC 62443-4-2, -40 to 75C operating temper by MOXA

Moxa NPort 6650-32-G2-T - 32-port RS-232/422/485 secure device server, certified with IEC 62443-4-2, -40 to 75C operating temper
by MOXA

Write a review Write a review
  • Data encryption with secure operation modes for Real COM, TCP Server, TCP Client, Pair Connection, Terminal, and Reverse Terminal
  • Secure Boot only allows Moxa-authorized firmware to run on devices
  • One-click log collection and application analysis for easy troubleshooting
  • Easy RS-485 configuration of serial interfaces with software-adjustable pull high/low resistor and terminator
  • Supports SSL certificate signing by RSA-4096 / ECC-521
  • IEC 62443-4-2 Security Level 2 certified
Mfg SKU # : NPort 6650-32-G2-T
Our Price : $2,545.00
Stock : Call for Availability
Quantity :

Moxa NPort 6650-32-G2-T

The NPort® 6000-G2 Series is a next-generation secure device server designed to provide secure, reliable, and easy-to-manage serial-to-Ethernet connectivity for industrial applications. A management console supports HTTPS with TLS 1.2/1.3, while serial data transmitted over Ethernet can also be protected with TLS encryption to ensure communication security and data integrity. Designed for seamless integration with enterprise IT security infrastructure, the NPort® 6000-G2 supports RADIUS and TACACS+ authentication, SNMP Inform/Trap for centralized event monitoring and alerts, and remote syslog for security auditing. Primary and backup server configurations are supported to enhance service availability and reliability. For easier serial port configuration and troubleshooting, the NPort® 6000-G2 provides software-configurable pull high/low resistors and terminators, along with a one-click application analyzer to help users quickly identify communication issues during on-site maintenance.

IEC 62443-4-2 Security Level 2 Certified: The NPort 6600-G2 Series is IEC 62443-4-2 Security Level 2 certified, making it easier for asset owners and system integrators to integrate IIoT applications by providing a secure platform that has already been tested and validated to protect IIoT data and infrastructure against cyberthreats

Secure Data Transmission: For many applications, guaranteeing secure data transmission is an important concern when connecting serial devices to a network. To answer this concern, the NPort® 6600-G2 secure terminal servers support the TLS and SSH protocols, which work by encrypting data before sending it over the network. With the NPort® 6600-G2, you can be rest assured that serial data is transmitted securely over both private and public networks

One-click Logs and Application Analysis for Easy Troubleshooting: During the deployment stage, system integrators must connect devices and ensure the communication is smooth. They may encounter issues and will require tools to troubleshoot issues. Moxa provides a application analyzer that generates a report at the click of a button to help the system integrator easily identify potential issues and understand how to resolve them. At the maintenance stage, system errors may require you to call for help. Device vendors might take a long time to troubleshoot issues because they need to collect information and then hold discussions with the technical support team. The NPort 6600-G2 comes with a one-click log collection function, which can provide all the data that a technical support team needs to quickly troubleshoot system issues.

Specifications

  • Ethernet ports: 2 x 10/100/1000M RJ45
  • No. of Serial ports: 32
  • Serial Standards: RS-232/422/485
  • No. of power cables included: 1
  • Operating temperature: -40~75ºC
  • SD Slot: microSD card, up to 2 TB (high speed, 25 Mbps)
  • Magnetic Isolation Protection: 1.5 kV (built-in)
  • Configuration options: Web Console (HTTP/HTTPS), Windows Utility, Device Search Utility (DSU), MCC Tool, Serial Console
  • Management: ARP, DHCP Client, DNS, HTTPS, ICMP, IPv4/IPv6, SMTP, SMTPS, SNMPv1/v2c/v3, SNTP, TCP/IP, UDP, WINS
  • Window Real COM Drivers:
    • Windows 11, 10, 8.1, 8, and 7
    • Windows Server 2022, 2019, 2016, 2012 R2, 2012, and 2008 R2
  • Linux Real TTY Drivers: Kernel versions 6.x, 5.x, and 4.x
  • Fixed TTY Drivers: macOS versions: 14, 13, 12, and 11
  • Arm-based platform support
    • Windows 11
    • Linux kernel 6.x, 5.x, and 4.x
    • macOS 14, 13, 12, and 11
  • Virtual Machine
    • VMWare ESXi (Windows 11/10/8.1/8/7 & Linux 6.x, 5.x, and 4.x)
    • VMware Fusion (Windows on macOS 14, 13, 12, and 11)
    • Parallels Desktop (Windows on macOS 14, 13, 12, and 11)
  • Time management: SNTP client
  • MIB:
    • MIB-II
    • RFC1213, RFC1317
    • Private MIB
  • Unicast Routing
    • RIPV1/V2
    • Static Route
  • Root of Trust
    • Secure Boot
    • True Random Number Generator (TRNG)
    • Security Screws
  • Authentication
    • Local database
    • RADIUS
    • TACACS+
  • Security Protocols
    • HTTPS (TLS 1.2/1.3)
    • SNMPv3
    • SSHv2
  • Encryption
    • HTTPS: ECC-256, ECC-384, ECC-521, RSA-1024, RSA-2048, RSA-3072, RSA-4096, AES-128, AES-256, CHACHA20, SHA-256, SHA-384, HMAC
    • SSH: ECC-256, ECC-384, ECC-521, RSA-2048, AES-128, AES-256, SHA-256, SHA-384, HMAC
    • SNMPv3: AES-128, SHA-256, SHA-384
    • Secure OP mode: HTTPS: ECC-256, ECC-384, ECC-521, RSA-1024, RSA-2048, RSA3072, RSA-4096, AES-128, AES-256, CHACHA20, SHA-256, SHA-384, HMAC
    • Config import/export: AES-256, SHA-256, HMAC
  • Connector: 8-pin RJ45
  • Secure Operation modes: Reverse SSH, Secure Pair Connection, Secure Real COM, Secure TCP Client, Secure TCP Server, SSH, Secure Redundant COM, Secure Reverse Real COM
  • Standard Operation modes: Disabled, Pair Connection, SLIP, PPP, Real COM, Reverse Terminal, RFC2217, TCP Client, TCP Server, Terminal, UDP, Redundant COM, Reverse Real COM
  • Bitrate: 50 bps to 921.6 kbps (supports non-standard baudrates)
  • Data bits: 5, 6, 7, 8
  • Stop Bits: 1, 1.5, 2
  • Flow Control: None, RTS/CTS, DTR/DSR, RTS Toggle, XON/XOFF
  • Parity: none, even, odd, space, mark
  • RS-485 data direction control: automatic data direction control (ADDC)
  • Terminator for RS-485: 120 ohms (software-configurable)
  • Pull High/Low resistor for RS-485: 1 kilo-ohm, 150 kilo-ohms
  • Input current: 340 mA (max.)
  • Input voltage
    • AC models: 100 to 240 VAC, 50 to 60 Hz
    • DC models: ±48 VDC (20 to 72 VDC, -20 to -72 VDC)
  • Housing: metal
  • Installation: Desktop, Rack mounting (RK-43-01, included in the box)

Copyright © 2026 iComTech. All rights reserved. Shopping Cart Software powered by ecMidas.